Minecraft 1.15 Download

Minecraft 1.14.4 Download

Minecraft 1.13.1 Download

Minecraft 1.12 Download

Minecraft 1.11.2 Download

Minecraft 1.7.10 Download

Minecraft 1.10.2 Download

Minecraft 1.9 Download

Minecraft 1.8.8 Download

Minecraft 1.8.7 Download

Minecraft 1.8.6 Download

Minecraft 1.8.4 Download

Minecraft 1.8.3 Download

Minecraft 1.8.2 Download

Minecraft 1.7.2 Download

Minecraft  LunatriusCore 1.11/1.10.2/1.7.10

LunatriusCore 1.11/1.10.2 is a required mod in order for any of the other mods to work in 1.7.2 or later. It contains the core shared classes used by all mods Lunatrius release. If you don’t install it along with any of the other mods here, Minecraft will crash. You have been warned! How to install  [ Okumaya Devam ]