CompatLayer 1.11.2/1.10.2 is a small library/mod that allows you to write mods that run on 1.10.2 and 1.11 with the same binary jar. At least upto some point.